Digital Camera Speed

copyright (c) 2003 Peter Šlosar

autor programu: | Peter Šlosar
www autora: | http://slosar.tripod.com
www programu: | http://slosar.tripod.com/dcspeed
e-mail: | slosar@yahoo.com

Digital Camera Speed je freeware. Licenčné ujednanie sa nachádza v súbore LICENCIA.TXT.

Program Digital Camera Speed je určený pre meranie rýchlosti digitálnych fotoaparátov. Ide o stopky prispôsobené špecifikám uvedeného merania. Dôraz je kladený na odčítavanie merania fotením, kedy nameraný čas je zachytený na exponovanej snímke.

Prostredníctvom programu je možné merať nasledovné časové intervaly digitálneho fotoaparátu:
- čas od zapnutia fotoaparátu do prvého odfoteného záberu,
- čas omeškania spúšte fotoaparátu bez nameraných hodnôt,
- čas omeškania spúšte s nameranými hodnotami,
- meranie času, ako rýchlo aparát fotí obrázky jeden za druhým,
- meranie rýchlosti zoomu,
- meranie rýchlosti času medzi zobrazením dvoch záberov v režime prezerania.
Program umožňuje jednotlivé namerané časy uchovávať a počítať ich priemer, pričom sadu meraní s vypočítaným priemerom je možné exportovať do súboru.

Program pracuje na Microsoft Windows 95/98/ME/NT4/2000/XP (doporučený Microsoft Windows 2000/XP).

Poznámka

Program bol pôvodne vyvinutý na podnet a pre potreby autora serveru www.digi-foto.sk, Mira Veselého, ktorý je i autorom časti nápovedy, praktického návodu "Ako merať".


Popis programu

Nastavenie merania

Režim Štart-Stop | V tomto režime sa počíta čas od štartu po ukončenie. Tlačítkom ŠTART spustíte počítanie a opakovaným stlačením toho istého tlačítka, prepnutým do funkcie STOP, ho ukončíte. Meria sa čas od štartu po stop. Nasledujúce meranie sa znova spustí stlačením tlačítka ŠTART.
Režim Štart-Štart | V tomto režime sa meria interval medzi stláčaním tlačítka ŠTART. Po prvom stlačení tlačítka ŠTART sa zaháji počítanie času. Ďalšie stlačenie tlačítka ŠTART ukončí počítanie, resetuje čas na nulu a zároveň započne ďalšie počítanie času. Cyklus meraní v tomto režime je možné ukončít klávesou ESC.
Interval merania | Nastavenie časového intervalu časomiery. Pri hodnote 0,01 s bude zobrazovaný čas na stotiny sekúnd. Tak hustú frekvenciu zmien však často nestíha zobraziť monitor, ani zachytiť fotoaparát, preto sa dá prepnúť interval na 0,02 s. S ním sa už dá ako-tak pracovať aj na lepších LCD monitoroch. Pre prípad problémov je k dispozícii aj interval 0,05 s alebo 0,1 s.
Čas odpočtu | Nastavenie, koľko sekúnd pred začiatkom merania má prebiehať odpočet. Ak zvolíte napríklad 3 sekundy, po stlačení tlačítka ŠTART sa najskôr tri sekundy bude odpočítavať (3, 2, 1...), potom sa na moment zjaví červený nápis ŠTART a od tej chvíle sa počíta čas. Pre odpočítavanie času odporúčam hodnotu aspoň 7 sekúnd, aby ste sa trafili do rytmu sekundového odpočtu. Vrelo odporúčam počas testu nepočúvať hudbu, môže ovplyvniť schopnosť v duchu sa synchronizovať so sekundami, ak prijímate ešte iný rytmus.
Počítať priemer časov | Funkcia, ktorá umožní pri opakovaných meraniach zistiť ich priemernú dĺžku trvania. Keďže koordinácia rúk nie je celkom dokonalá, je lepšie všetky merania zopakovať niekoľkokrát a ako výsledok použiť ich priemer. Koľkokrát treba merať? Čím viac sú si výsledky prvých meraní podobné, tým menej. Po stlačení merania spravidla sami cítite, či ste stlačili tlačítko celkom presne. Ak ste si istí niekoľko krát za sebou a výsledky sú zároveň skoro rovnaké, netreba veľa meraní. Tiež závisí na tom, ako vám záleží na presnom výsledku.

Nastavenia programu

Jazyk | Voľba jazyka užívateľského interfejsu programu.
Font časomiery | Voľba písma časomiery. Je možné nastaviť typ písma, jeho veľkosť a rez. Štandardné nastavenie je na Arial, 120 bodov, Bold.

Tlačítko Štart/Stop

Spustí a zastaví počítanie času. Tlačítko plní funkciu ŠTART i STOP, podľa toho, v akej fáze sa meranie nachádza.

Zobrazenie času

Číselný údaj o bežiacom čase. Číselný údaj je zobrazovaný veľkým písmom, aby sa dal z obrazovky dobre fotografovať.

Číselný ukazovateľ | Zobrazuje meraný čas v sekundách s presnosťou na stotiny sekundy. Prevod do tvaru hodiny:minúty:sekundy nie je podporovaný, pretože tak dlhé časové údaje sa u meraní rýchlosti fotoaparátu nepredpokladajú.
Grafický ukazovateľ | Rýchle striedanie číslic sa nedá dobre fotografovať, preto je tu ešte grafický ukazovateľ času, ktorý pomáha zobraziť stotiny sekundy v grafickej podobe. Na mnohých monitoroch budú stotiny sekundy po odfotení zobrazené tak, že sa bude prelínať viac číslic – obraz číslic nestihne tak rýchlo pohasnúť.

Priemer meraných časov

Pri opakovaných meraniach je možné zaškrtnúť voľbu "Počítať priemer časov". Vtedy je nad prehľadom nameraných časov zobrazený počet meraní, celková suma nameraných časov a ich výsledný priemer.
V prehľade meraní je k dispozícii kontextové menu, ktoré sa zobrazí po stlačení pravého tlačítka myši.

Vymazať zvýraznený čas | Pokiaľ niektoré meranie je nutné vymazať, aby sa nezapočítavalo do celkového priemeru, je nutné tento čas označíť ľavým tlačítko myši, pravým tlačítkom myši vyvolať kontextové menu a zvoliť vymazanie zvýrazneného času.
Vymazať všetky časy | Vymazanie všetkých časov z prehľadu nameraných časov.
Export | Exportovanie prehľadu nameraných časov do textového súboru.


Ako merať

Praktický návod k programu, "Ako merať", napísal Miro Veselý, autor serveru www.digi-foto.sk.

Online verzia sa nachádza na www.digi-foto.sk/softver/meranie-rychlosti-digitalneho-fotoaparatu.php


Ako nastaviť fotoaparát na meranie

Ak si váš prístroj pamätá posledné nastavenia, odporúčam vypnúť blesk a zoom stiahnuť na minimálnu úroveň, teda do najširokouhlejšieho stavu. Citlivosť môžete dať čo najvyššiu. Ja pri testoch používam režim automatiky s vypnutým bleskom.

Možné problémy pri meraní

Rýchlosť štartu fotoaparátu je ovplyvnená niekoľkými faktormi, pri meraniach je potrebné na ne myslieť.

Veľkosť pamäťovej karty | Ak použijete na meranie maličkú kartu dodanú k fotoaparátu, veľmi často nameriate omnoho kratšie časy štartu, ako v prípade, že meriate ten istý fotoaparát, ale s veľkou pamäťou.
Nehýbte aparátom | V tmavšom prostredí sa ťažšie zaostruje, ak budete prístrojom v rukách hýbať, výrazne sa predĺži čas, ktorý fotoaparát potrebuje na zaostrenie. O tento čas sa omešká expozícia. Statív je ideálny, no zas na druhej strane nie je nutné dosiahnuť za každú cenu najvyššiu rýchlosť – tú nech si uvádza výrobca v reklame. Držte aparát v rukách, ale primerane pevne. Získate nie ideálne krátku hodnotu, ale ani nie zbytočne dlhú.
Vypnite blesk | Ak to fotoaparát umožňuje, vypnite blesk. Monitor je totiž pomerne tmavý objekt a nabíjanie blesku môže predĺžiť čas, ktorý aparát potrebuje na odfotenie prvého záberu.
Nepresné stlačenie spúšte | Reflexy človeka nie sú až tak dokonale presné, ak sa začneme pokúšať o presnosť na stotiny sekúnd. Aj keď sa sekundové odpočítavanie dá pomerne presne odhadnúť, stlačiť spúšť naozaj presne vtedy, keď vidíte nápis ŠTART nie je vôbec ľahké. Sami uvidíte, aký veľký odpad nevydarených záberov vyprodukujete. Raz odfotíte v predstihu – ešte v momente, keď je zobrazené posledné číslo odpočítavania, inokedy sa omeškáte. Našťastie naše zmysly sú dosť vnímavé na to, aby ste ihneď po odfotení cítili, či ste spúšť stlačili presne, alebo nie.
Nepozerajte sa na LCD, ale očami na monitor | Veľká väčšina digitálnych fotoaparátov zobrazuje na LCD mierne omeškaný obraz. Toto omeškanie má niekedy aj desatinu sekundy a mohlo by sa pripočítať k výslednému času merania.
Výsledky hodnoťte opatrne | Pri fotení z obrazovky sa expozičný čas fotoaparátu zvykne pohybovať približne na úrovni pätnástiny sekundy. Za ten čas sa na monitore stihne zobraziť niekoľko čísiel. To, spolu s nedokonalým zobrazením čísiel na monitore spôsobí, že budete vidieť niekoľko čísiel naraz. Presné údaje si preto odvodíte až analýzou kombinácie grafického ukazovateľa a číslic zobrazeného času.


Čas od zapnutia fotoaparátu do prvého odfoteného záberu

Program prepnite do režimu Štart-Stop. Čas odpočtu nastavte napríklad na 10 sekúnd. Vypnite fotoaparát. Stlačte tlačítko ŠTART a sledujte odpočítavanie 10, 9, 8... V momente, keď sa mihne červený nápis ŠTART, zapnite fotoaparát a namierte ho na obrazovku monitoru. Snažte sa odfotiť snímku obrazovky tak rýchlo, ako to zapínajúci sa fotoaparát umožní.

Čas, koľko trvá zapnutie fotoaparátu až po prvý záber budete vidieť na LCD fotoaparátu – je to čas, ktorý fotoaparát odfotil.


Čas omeškania spúšte fotoaparátu bez nameraných hodnôt

Meranie prebieha rovnakým nastavením programu, ako v predchádzajúcom prípade.

Po stlačení tlačítka ŠTART namierte fotoaparát na nejaký vzdialený predmet v miestnosti, aby bol zaostrený na niečo, čo ale v skutočnosti nebudete fotiť. Tesne predtým, čo sa na obrazovke zobrazí červený nápis ŠTART rýchlo namierte aparát na obrazovku a čo najmenej ním už ďalej hýbte. V momente, keď sa zobrazí nápis ŠTART stlačte spúšť nadoraz a snažte sa aparátom nehýbať. Výsledky merania si pozriete na LCD fotoaparátu.

Pri fotení tohto testu platia rovnaké odporúčania, ako v predchádzajúcom prípade, akurát blesk – ak by bol zapnutý – neovplyvní rýchlosť, pretože už je nabitý. Ale blesk by pravdepodobne silne zneviditeľnil čísla na obrazovke a asi by na nej veľa vidieť nebolo.


Čas omeškania spúšte s nameranými hodnotami

Rovnaké nastavenia programu, ako v predchádzajúcom meraní.

V čase odpočítavania sekúnd zaostrite fotoaparát a namerajte hodnoty tak, že zameriate na obrazovku a s napoly stlačenou spúšťou vyčkáte, kým fotoaparát nedá signál, že je pripravený fotiť. Prst už zo spúšte neuvoľnite, ale vyčkajte, kým sa zobrazí nápis ŠTART. V tej chvíli exponujte.

Výsledky merania uvidíte na odfotenom obrázku, najlepšie ak si ihneď po odfotení záberu zapíšete, či ste s meraním tohto čísla obrázku spokojní. Toto meranie je najkritickejšie na presnosť! Práve tu bývajú v hre stotiny sekúnd. Tento test bude preto treba vyhodnotiť presnejšie a výhodnejšie je to robiť až v počítači. Nie na každom LCD fotoaparátu sa zobrazí obraz tak jasne, že sa dá odčítať aj pomerne svetlý obraz stotín sekúnd.


Meranie času, ako rýchlo aparát fotí obrázky jeden za druhým

Tu máte na výber.

- Môžete fotografovať časomieru, jeden obrázok za druhým, tak rýchlo, ako aparát dovolí a výsledky zistíte z časov na skutočných fotkách. Pre matematických antitalentov, ako som ja, je však pokus vypočítať frekvenciu fotenia z hodnôt „4,6“, a „7,9“ sekúnd vyčerpávajúce. K číslu 3,3 sekundy sa dopracujem až po pol minúte, počas ktorej musím postupne kývať až šiestimi prstami a ani tak nie som istý, či je toto číslo správne (ani to, či som kýval správnymi prstami...).

- Môžete fotiť v režime Štart-Štart, pri každom odfotení obrázka (počujete cvaknutie) stlačíte tlačítko ŠTART. Táto metóda je rýchla a pohodlná a môžete poľahky spraviť aj 20 meraní za sebou, čím sa minimalizujú prípadné chyby pri stlačení medzerníka.

Môžete síce namietnuť, že človek tlačítko ŠTART nestlačí presne, ale pri tomto meraní zas spravidla nejde o žiadnu striktnú presnosť. Rýchlosť fotoaparátu je aj tak ovplyvnená aj podmienkami pri fotení, ďalší záber je omeškaný nielen o čas, kedy sa predošlý ukladá do pamäťovej karty, ale aj časom potrebným na zaostrenie. A tento čas je vždy premenný. Preto nejaká drobná desatinka hore-dolu nehrá žiadnu úlohu.


Meranie rýchlosti zoomu

Využijete na to režim Štart-Štop. Odpočítavanie pred meraním nastavte na nulu. Páčku so zoomom a tlačítko ŠTART stlačte zároveň. Počujete, ako zoom bzučí. Keď dobzučí, stlačte tlačítko STOP. Časomiera sa zastaví na čase, koľko trvá zoomu jedna jazda. Môžete zapnúť počítanie priemeru času, aby ste opakovaným meraním získali presnejší výsledok.

Pri meraní rýchlosti posunu zoomu však počítajte aj s tým, že niektoré fotoaparáty majú rozdielne dlhý čas pre obidva smery jazdy. Ak to je váš prípad, merajte v sérii opakovaných meraní vždy len jazdu jedným smerom.

Tento test je dobré doplniť aj kontrolou odozvy zoomu. Tu program nevyužijete, je to len tip na dokreslenie vlastností fotoaparátu.
Pokúste sa zoomom nastaviť také priblíženie, aby sa (napríklad) zobrazenie okraju obrazovky monitoru presne „dotýkalo“ okrajov LCD na fotoaparáte. Približujte a odďaľujte obraz. Ako rýchlo sa dopracujete k presnému zákrytu?...Ehm – a dopracujete sa k nemu vôbec? Niektoré fotoaparáty majú ovládanie motorčeka zoomu veľmi oneskorené.

Ak sa zoomu „dotknete“ aj celkom krátko, rozbehne sa až po kratučkej pauze a pobeží istú dráhu, kým sa zastaví. Kratšia dráha sa dosiahnuť nedá. Ak je dĺžka tejto dráhy dosť veľká, zoom sa často nedá umiestniť do vzdialenosti kratšej, než najkratšia jazda. Niektoré aparáty to riešia tak, že v opačnom smere je jazda zoomu krokovaná s inou dĺžkou dráhy a tak sa postupným približovaním a odďaľovaním zoomu postupne dostanete na požadovanú úroveň zoomovania. Iné aparáty však majú v obidvoch smeroch najkratšie možné jazdy rovnaké a tak dopracovať sa ku nejakej konkrétnej hodnote priblíženia takmer úplne nemožné. Ostatne práve preto na čo i len trochu profesionálnejších fotoaparátoch je zoom ovládaný viacrýchlostným motorom. No a najlepšie aparáty nemajú žiadny motor. Fotograf má ruku, nech si krúti, ako sa mu uráči...


Meranie rýchlosti času medzi zobrazením dvoch záberov v režime prezerania

Na toto meranie využijete režim Štart-Štart, alebo Štart-Stop, ako vám vyhovuje lepšie. V obidvoch prípadoch nie je potrebné odpočítavanie.
Ak chcete byť pri meraní veľmi presný, môžete merať nasledovné hodnoty:
- čas, ktorý uplynie medzi stlačením tlačítka „ďalší obrázok“ a skutočným zobrazením nasledovného obrázka,
- čas, ktorý uplynie medzi zobrazením záberu a jeho nahradením fotkou v plnej veľkosti.
Prvý údaj je dôležitý, druhý už je skôr len pre zaujímavosť – mnoho fotoaparátov, aby urýchlilo prácu zobrazuje na LCD najskôr len hrubý náhľad, aby používateľ nebol nervózny. Aparát však stále ďalej pracuje – načítava dáta plnej verzie obrázku a zmenšuje ho na veľkosť LCD. Tento proces zvykne trvať asi sekundu, aj viac – závisí na počte megapixelov fotoaparátu. Potom, čo má skutočný obrázok načítaný, nenápadne ho na LCD zamení za predtým zobrazený náhľad.
Táto zámena sa dá pozorovať voľným okom – obraz sa zrazu viditeľne zaostrí, asi po sekunde zobrazenia.
Iné fotoaparáty na LCD vôbec nezobrazujú plnú verziu obrázku. Zobrazia iba náhľad a čakajú na ďalšie pokyny. Ak je ďalší pokyn zväčšiť obrázok, nasleduje pauza – až počas nej načítava aparát dáta, aby zobrazil zväčšeninu. Je to o hodne pomalšie, ale zas to môže ušetriť trochu energie v baterkách.